Overview

BuzzCalc scans and analyzes webpages in real time using Excel. It does this in a few steps:

  1. BuzzCalc gathers web pages
  2. The text is broken down into words
  3. Excel shows patterns and popularity of words over time.

BuzzCalc runs separately from Excel. It is an engine that you control. You tell it what web sites to scan, when to fetch and what to store. BuzzCalc runs in the background analyzing word patterns. Your Excel formulas link to it and get results.

Features:

  • Real-Time: Results appear immediately in Excel
  • Private: Your models are on your computer, not in the cloud
  • Many Formats: HTML Webpages, RSS, ATOM, Generic XML
  • Retrieval Scheduling: Manually set or determine automatically
  • Limitless Data: As much as your PC's drive will hold
  • Search: Track single words or complex phrases using wildcards
  • Ignore List: Set words that you don't care to track (a, an, the...)
  • Save List: Set words that are never purged when the database gets big
  • Aggregation: Tags combine multiple websites into one result

Requirements:

  • Microsoft Excel: Version 2003 or later
  • Windows: XP or later, .NET Framework v4.51 or later
  • Disk Storage: At least 30G free space recommended

Continue with Getting Started

Main Website: BuzzCalc.com
Discuss, Comments, Problems: Forum
Email Support: support@leftek.com


Getting Started

Add Feeds

BuzzCalc pre-installs a few practice feeds. Use these or set up your own. More information here: Feeds

Turn On Engine

Turn the On/Off switch 'On'. That's it! The 'Activity' tab will start showing what is happening.

The 'Stats' tab will will display the most popular phrases coming in. If you find some single words not relevant (a, an, the...), right click on them and add them to the 'Ignore List'.

Open Excel

Start a new workbook. In a blank cell enter:

=BuzzTopWords(1)

The most popular word from all your feeds will appear. If you change the argument to a (2) , you will see the most popular two-word phrase. It will change as new information is received. More information here: Excel Functions

Categorize Feeds

Have Excel query specific feeds for popular words by grouping them together. To do this, label them with Tags. More information here: Tags


Application Engine

The Engine is an application that runs on its own, separate from Excel. It stays in the background, down in the taskbar, while you do other work.
Excel does not have to be open to run the Engine. However the Engine does have to be running to use BuzzCalc functions in Excel.
The task bar icon shows activity and opens the application:
Tabs


Menus

File

Import/Export Configuration

The 'File' menu at the top has the option to export and import the BuzzCalc setup. Included are:

  • Feeds and their Tags
  • Ignore Words
  • Retain Words

Help

License Registration

Trial

BuzzCalc has a 30 day trial period. To continue the trial after expiration, you may uninstall BuzzCalc and reinstall it again. All data however will be removed. There is no limit on reinstallations.

Full Version

Follow the link on the registration window to purchase. You should receive your license key shortly afterwards. If there are any problems, please email support@leftek.com.


Tabs

Feeds

Tags

Settings

Ignore

History

Activity

Statistics


Feeds

Main Information

Name

Your own name for the feed, an identifier. It should probably be easier to read than the URL. Must be unique.

Web URL

The webpage's internet address. This also must be unique. Any valid URL can be entered, but keep in mind that for BuzzCalc to read the page, it must be in one of the following formats:

  • HTML
  • RSS
  • Atom
  • Generic XML

Site Information

More than one of your feeds may access the same site. These settings apply to all of these feeds.

Same-Site Pages Wait Time

Some sites don't like it when you 'hit' them too frequently. Here you set a delay used between each fetch. Set to zero if no delay desired.

Login Information

FTP sites and network drives usualy require a username and password. Most websites do not.

Note that this does not apply to websites that have you log in through a login page. It only applies to sites that pop up a small dialog box prompting for username and password.

Behavior

Set for multiple feeds by selecting more than one from the listbox.

Active

If engine is on, should this feed be retrieved?

Include Linked Pages

Off: Only the single page of the feed will be scanned.
On: First the feed will be scanned. Second, directly linked pages will be scanned. Only links from the feed will be included. Links from the linked pages will not be included.

Refresh Frequency

How often should the feed be scanned? You can let BuzzCalc figure this out for you. By selecting 'Automatic', BuzzCalc constantly adjusts the refresh timing based on how frequently it sees new data. You may also set a constant frequency yourself.

Tags

Simply shows the tags selected for this feed on the Tags Tab.


Tags

Tags are used to categorize your feeds for easy aggregation and computation. For instance, if you are scanning news feeds, you might assign tags like this:

 | EXAMPLE TAGS
Feeds | General | AsiaNews | EuroNews
Yahoo News China | √ | √ |
Google News Japan | √ | √ |
Yahoo News France | √ |  | √
Google News Germany | √ |  | √

Excel looks information up in BuzzCalc based on Tags, not on individual feeds. So even if you only have one feed you want to target, you still need to give it a tag. If you don't enter any tags, Excel formulas will target all your feeds aggregated together.

A tag must be all one word, no spaces. Up to 255 Tags can be added.


Settings

General

Start App When Computer Starts

If this is set, BuzzCalc will start and the Engine switch will automatically turn on.

Feed Defaults

These can be set for an individual feed, but if nothing is set, the feed will use these defaults. See the Feeds Tab for more information.

Fetches

These apply each time a page is fetched:

Web Page Timeout

Sets the number of seconds to try before giving up on a fetch.

Same-Site Pages Wait Time

This is a default for all sites. It can be set specifically for individual sites as well. See the Feeds Tab for more information.

Excel

Function Time Limit

Calls from Excel can use up a lot of processing power. This can happen if there are too many search parameters or the time span to search is too large. Limit the strain placed on the PC by setting the maximum number of seconds that a function can run for. If this is exceeded, Excel will display "ERROR".

Web Proxy Server

A web proxy is used if you need to 'bounce' through a gateway computer to get onto the internet. This may be needed in companies that have firewalls or with VPN web servers.

Server(:Port #)

The server format can be either an:

  • IP Address- eg: XXX . XXX . XXX . XXX
  • Web Site Name- eg: companyproxy.companyname.com

Do not prefix with anything (like HTTP://). A port number can be added using a colon. Eg: ourproxy.companyname.com:8080


Ignore List

Queries for 'most frequent words' will often turn up many insignificant words, cryptic symbols and single letters. These can be eliminated from the results by adding them to the 'Ignore List'.

Searching for 'most frequent phrases', consisting of two or more words, will also take this list into account. Any phrase starting or ending with an 'ignore word' will be ignored. For example:

Ignore List: | # Words | Phrase Ignored | Not Ignored
"the" | 3 | "the United States" | "Mack the Knife"
"of" | 4 | "Of Mice and Men" | "United States of America"

However if the # of Words were shortened:

"the United States" -> "United States"
"Of Mice and Men" -> "Mice and Men"

These would both be found.


History

Days of History

BuzzCalc stores each and every word retrieved. You probably don't need to keep all of these forever. How long should words be kept?

This depends on how many feeds you are watching how much disk space is available. Monitor the data and your disk drive here. If the size becomes very big, it can slow down your PC.

First try to compact the database. If the size is still too big, reduce the number of days above accordingly.

Compact Database

This may take quite a while. A message will appear next to the button when done.

Retained Words List

Even though most words are unimportant and should be purged, some words that you are tracking should be kept infinitely.

List them here and when the database periodically trims itself down to the number of days you specified by purging old data, fetches containing these words will not get deleted.


Activity

Excel

  • Connections: How many Excel workbooks are connected to BuzzCalc.
  • Data Points: How many BuzzCalc functions are being used from Excel.

Feed List

Show

Display all feeds or only active ones currently queued.

Fails

The number of times a connection has failed to be made.

After one failure, BuzzCalc will try again within a minute. If failures continue, the retry time will gradually be increased. After many failures, BuzzCalc will retry about once every day.

Log

The latest message is shown next to the feed. To see the full history, double-click the feed.


Statistics

These stats are updated in real-time whenever new data arrives. Enable them only if you need to since they will put extra load on the database.

Top Words

Displays top single words as well as phrases of 2, 3 and 4 words. Words from the single word list can be selected and added to:

Ignore Words List: These words will not show up in Top Words queries. See the Ignore Tab for more information.
Retain Words List: These words are preserved permanently, even when the database reaches it's limit and old data is purged. See the History Tab for more information.

Words Today

Displays an overview of activity today. This can be used to verify that BuzzCalc was up, running and connected.


Excel

Functions

Function Parameters


Excel Functions

Excel functions are all prefixed with "Buzz".

BuzzHeartbeat()

BuzzActivity()

BuzzFetchNameEarliest/Latest()

BuzzFetchTimeEarliest/Latest()

BuzzFetchTextEarliest/Latest()

BuzzCount()

BuzzTopWordsArray()


Function - BuzzHeartbeat()

Description:

Gives a visual signal that the BuzzCalc engine and Excel are talking to each other. A heartbeat is sent to Excel every few seconds.

If no argument is given, the last time a Heartbeat was recieved is displayed. Otherwise it counts up between zero and [CountUpTo], incrementing with each Heartbeat received.

Arguments:

  1. CountUpTo: The top number to reach after which the count resets to zero and starts over. (optional value)

Example:

=BuzzHeartbeat()

To make an animated rotating display, try this formula:

=IF(BuzzHeartbeat(3)=0,"|",IF(BuzzHeartbeat(3)=1,"/",IF(BuzzHeartbeat(3)=2,"-","\")))


Function - BuzzActivity()

Description:

Gives a visual signal when a webpage is scanned (regardless of new data or not).

If no argument is given, the last time there was Activity is displayed. Otherwise it counts up between zero and [CountUpTo], incrementing with each time there is Activity.

Arguments:

  1. CountUpTo: The top number to reach after which the count resets to zero and starts over. (optional value)

Example:

=BuzzActivity()

To make an animated rotating display, try this formula:

=IF(BuzzActivity(3)=0,"|",IF(BuzzActivity(3)=1,"/",IF(BuzzActivity(3)=2,"-","\")))


Function - BuzzFetchTimeEarliest(), BuzzFetchTimeLatest()

Description:

The earliest/latest time that data was recieved. Omit all arguments to find the first/last time for all fetches.

Arguments:

  1. Search Term(s): Result will be for the earliest/latest of any of these search terms. More information on search terms. (optional value or range)
  2. Tag(s): Result will be the earliest/latest feed haiving any of these tags. (optional value or range)
  3. Start Date/Time: The starting Date/Time from which this should be computed. (optional value)
  4. End Date/Time: The ending Date/Time to which this should be computed. (optional value)
  5. N Times: The number of times back/forward from the earliest/latest time data was seen. A '1' for the very first/last time data was seen, '2' for 2nd time, etc. (optional value, default 1)

Example:

=BuzzFetchTimeEarliest("Cyberdyne Systems", "MergerAcquisitions")


Function - BuzzFetchNameEarliest(), BuzzFetchNameLatest()

Like BuzzFetchTimeEarliest/Latest() except returns the Feed Name instead of retrieval time.


Function - BuzzFetchTextEarliest(), BuzzFetchTextLatest()

Like BuzzFetchTimeEarliest/Latest() except returns the page text instead of retrieval time.


Function - BuzzCount()

Description:

Count fetches or occurrences of a search term.

Arguments:

  1. Search Term(s): The search phrase to match. More information on search terms. (optional value or range)
  2. Count Fetches?: Within a single fetch, count multiple Search Term occurrences once or multiple times. (optional TRUE/FALSE, Default: FALSE)
    Eg. If a search term occures four different places in a single fetch, count it four times or once? If only once, set this to TRUE.
  3. Tag(s): Feeds with any of these tags will be included. (optional value or range)
  4. Start Date/Time: The starting Date/Time which this should be computed from. (optional value)
  5. End Date/Time: The ending Date/Time to which this should be computed. (optional value)

Example:

=BuzzCountTerms("Cyberdyne Systems", , "MergerAcquisitionsSites")


Function - BuzzTopWordsArray()

Description:

Gets the most popular words/phrases in Excel Array format. Returns a vertical two dimensional array.

  • Column #1: The list of words/phrases.
  • Column #2: Corresponding count of how many times each was found.

To display all results in an Excel Array, entering the function using Control-Shift-Enter. See example below. Also see Excel help for details on how to use Excel Arrays.

Arguments:

  1. Result Phrase Length (# of Words): Result should have how many words in a phrase? How many continious words in a row? (required value, default: 1, max: 4)
  2. Result List Length (Top how many): Result will be an Excel array containing this many words. (required value, default: 1, max: 100)
  3. Search Term(s): Limit to pages containing any of these search phrases. More information on search terms. (optional value or range)
  4. Tag(s): Limit to pages having any of these tags. (optional value or range)
  5. Start Date/Time: Fetches starting from this Date/Time should be searched. (optional value)
  6. End Date/Time: Fetches ending up to this Date/Time should be searched. (optional value)
  7. Word Proximity: Results only include words WITHIN this many words of search term's last word. Only applies within the same sentence. Irrelevant if [Words] not supplied. (optional value, default: no limit)
  8. Threshold Appearances: Results only include words that appear at least this minimum number of times. (optional value, default: 1)
  9. Omit Words: Results will not include these words. This is in addition to those listed on the App's Ignore Tab. (optional value or range)
    * Omit Words are slightly different than App Ignore Words. A result will be omitted if an Ignore Word is the first or last word. The result will also be omitted if any word is an Omit Word.

Example:

To display the full two-dimensional table of results:
  1. Select a 2-column by 10-row area of cells.
  2. Without clicking again on any cell, just start typing the formula: =BuzzTopWordsArray(1,10)
  3. Press and hold down the keys in order: Control-Shift-Enter


Excel Function Parameters

Most function parameters are self explanitory. However these require special explanation:


Parameter - Search Terms

Search Term

Finding matches is similar to a search engine like Google. For a basic search, if all the words in the search term appear anywhere on the same page, it is a match.

A word will also find 'fuzzy' matches. For example, searching for [plant] will also find [plants], [planted], [planting].

Proximity

Require words be near each other by using wildcards:

"*": Words are in order and separated by any amount. This is only for whole words, not partial words (wrong: "Uni* States").

"?": Words are in order and adjacent or separated by one word. Use "? ?" for up to two words, "? ? ?" for three, etc.

"=": Words are separated by exactly one word. They cannot be adjacent. Use "= =" for exactly two words, "= = =" for three, etc.

"^": Words are separated by one or more words. This is the opposite of '?'. Use "^ ^" for at least two or more words, "^ ^ ^" for three, etc.

Order

Unlike wildcards above, if it doesn't matter which word comes first, use:

"NEAR#": CAPS required. Words can be in any order and have up to "#" words between them. Use "NEAR0" for adjacent words.

"~": Shorthand for "NEAR0", adjacent words in any order.

Negation

"-": The word must not exist. Use before a word or phrase, eg: -word, -"some phrase". Cannot use inside quotes or with proximity wildcards (?, *, etc).

Exactness

If an exact spelling or phrase is desired, use quotes("). Proximity wildcards above also work inside quotes. eg: "Cyberdyne * T3".

Examples

Phrase | Matches
plant | plant, plants, planting
"plant" | plant
house plant | The house had many plants planted oaks in the housing development
three ? mice | three mice three blind mice
Google NEAR2 Apple | Google and Apple Apple partners with Google
water NEAR0 bottle | water bottles bottled water
"water NEAR0 bottle" | water bottle bottle water
Obama -Barack | Michelle Obama Obama and Clinton


Parameter - Start & End Times

Date/Time

Date/Times entered for BuzzCalc are rounded to the nearest minute.

Avoid: Try not to use auto-updating functions like =NOW(). Constantly updating values will cause Excel to recalculate all the time, putting strain on BuzzCalc and your PC.


About

Website: BuzzCalc.com
Discuss, Comments, Problems: Forum
Email Support: support@leftek.com

Copyright Information

©2013 - by Leftek Software